Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ASG RD 2015 protocol error 50331656 on Windows 10
#1
Hello,

I have a user who is experiencing an RDP protocol error (Return code: 50331656) when trying to connect to any of our servers. mstsc works normally from this machine, and he's able to use ASG from another machine to connect to the servers, just not this Windows 10 box. 

Attempted to modify the registry keys located in this post:
http://www.chicagotech.net/netforums/vie...=2&t=12014
but cannot locate them in Windows 10.

Any help would be greatly appreciated!

-JRobison
Reply
#2
I didn't found any better solution - do the user uses Windows Insider Preview Builds? Because I read one article that this was an issue in a preview build
Regards/Gruss
Oliver
Reply
#3
(01-08-2016, 11:10 AM)DevOma Wrote: I didn't found any better solution - do the user uses Windows Insider Preview Builds? Because I read one article that this was an issue in a preview build

I have reached out to the user, it does appear as if he's using the Preview Builds. Can you share this article?
Reply
#4
https://social.technet.microsoft.com/For...derPreview
Regards/Gruss
Oliver
Reply
#5
I am getting the same issue after upgrading to Anniversary Update of Windows 10. 

It works on normal RDP connections, but the connections that requires a RD gateway gives this error in ASG Remote Desktop 2016 Patch 3.

Have tried using Windows Remote Desktop with RD gateway and it works fine there, but not in ASG.

Have tried to reinstall ASG remote desktop also.

Note: I have also submitted a support ticket to ASG with this issue.
Reply
#6
(04-08-2016, 09:31 AM)Blacksmit Wrote: I am getting the same issue after upgrading to Anniversary Update of Windows 10. 

It works on normal RDP connections, but the connections that requires a RD gateway gives this error in ASG Remote Desktop 2016 Patch 3.

Have tried using Windows Remote Desktop with RD gateway and it works fine there, but not in ASG.

Have tried to reinstall ASG remote desktop also.

Note: I have also submitted a support ticket to ASG with this issue.

same Problem here :-(
Reply
#7
Which OS build number do you use?
Regards/Gruss
Oliver
Reply
#8
(04-08-2016, 10:28 AM)DevOma Wrote: Which OS build number do you use?

I am using 
Windows 10 Enterprise
Version: 1607
OS Build 14393.10
Reply
#9
Windows 10 Enterprise
Version: 1607
OS Build 14393.10
Reply
#10
Ok - I can reproduce on my "preview build machine" - on "standard win10" everything is working - some months ago we had a similar problem with "Server authentication" - and some weeks after the problem occurred a new Win10 build was published (by MS) and the problem was gone

In the link I added there is a solution how to remove the latest mstsc version - but as long as this is only a developer preview we can't change the program without to know if this is bug in this specific version or a change we have to implement too - if we change the mstsc interface (activeX) perhaps it will work for this version but not for the next one...
Regards/Gruss
Oliver
Reply
#11
Just a note
I am not using a developer preview.. It's a Standard Windows 10 Enterprise, upgraded with the latest SP (Anniversary Update, released on 2. August 2016)
Reply
#12
I´m also using the final release of Windows 10 Enterprise, upgraded with the latest SP (Anniversary Update, released on 2. August 2016).

No preview versions installed before.
Reply
#13
Ok - it's the same build OS version I have on my "preview machine" - I will check to install on a standard win10...
Regards/Gruss
Oliver
Reply
#14
I got it working as a workaround by replacing the mstscax.dll (Version 10.0.14393.0) in %windir%\SysWOW64\ with the "backup file" in "Windows.old\WINDOWS\SysWOW64" version (10.0.10586.494)

I had to take ownership of the file and give Administrators Full control access to be able to replace the file.
Reply
#15
You are a star!! I had exactly the same issue. All my TSGateway sessions to anything older than 2012 R2 were failing with this error. Your fix worked for me too.

Cheers

Rob
Reply
#16
We hope for a solution asap - but it takes some time to find the right persons at Microsoft :-)
Regards/Gruss
Oliver
Reply
#17
(05-08-2016, 12:46 PM)DevOma Wrote: We hope for a solution asap - but it takes some time to find the right persons at Microsoft :-)

Any update on this?  I'm still seeing the issue with connecting via a TS gateway with ASG version 9.0.5312.1 with the Windows 10 Anniversary Update.

Aaron
Reply
#18
Problem is send to dev in Redmond - waiting for feedback and a fix :-)
Regards/Gruss
Oliver
Reply
#19
(09-09-2016, 07:13 AM)DevOma Wrote: Problem is send to dev in Redmond - waiting for feedback and a fix :-)

I have the same problem after Win 10 update.
I can only connect to systems via Remote Desktop Gateway when I use mstsc outside of ASG remote desktop.
Reply
#20
Same problem here.

Any word back from Microsoft on this?
Reply




Users browsing this thread: 1 Guest(s)