Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
RDP Protocol Error 2056
#1
Hi,
Since we migrated to Win10 we had an error when we try to connect to a terminal server. No problem to connect to a standard server with RDP, no problem with Win7. Only terminal servers (win2008r2 or Win2012r2) from Win10.

We use ASG RD 2016. Extra info: no problem if we use mstsc.exe.

Complete error (see attachment):Return code 2056 "The remote computer disconnected the session because of an error in the licensing protocol"

Thanks in advance


Attached Files
.png   Capture.PNG (Size: 11.73 KB / Downloads: 5)
Reply
#2
Could you please try the following

1. Delete Registry items in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSLicensing
2. Close ASG-RD and start again as Administrator
3. Connect your server...
Regards/Gruss
Oliver
Reply
#3
Hi,

Is this verified to work? I have the same issue but ASG Remote Desktop is published on a terminal server so I can not delete this value.
Reply
#4
(06-03-2017, 10:47 AM)dst Wrote: Hi,

Is this verified to work? I have the same issue but ASG Remote Desktop is published on a terminal server so I can not delete this value.

Hi,
Yes the solution is working. We had the same problem, ASGRD is published with MS AppV v5. But we must manually remove the registry key. AppV doesn't remove the key.
Remarks: With a manual install, the key is automatically removed.

Rgds
Jonathan
Reply
#5
(06-03-2017, 11:11 AM)serverteam Wrote:
(06-03-2017, 10:47 AM)dst Wrote: Hi,

Is this verified to work? I have the same issue but ASG Remote Desktop is published on a terminal server so I can not delete this value.

Hi,
Yes the solution is working. We had the same problem, ASGRD is published with MS AppV v5. But we must manually remove the registry key. AppV doesn't remove the key.
Remarks: With a manual install, the key is automatically removed.

Rgds
Jonathan

Hi,

but I don't get this. The application is installed on a terminal server and the users launch ASG as a published application. Don't I need this key on my terminal server where the ASG-application is installed? This isn't a ASG-registry key.
Reply
#6
We are using mstsc-ActiveX - and the regkey is from mstsc...
Regards/Gruss
Oliver
Reply
#7
(08-03-2017, 12:36 PM)dst Wrote:
(06-03-2017, 11:11 AM)serverteam Wrote:
(06-03-2017, 10:47 AM)dst Wrote: Hi,

Is this verified to work? I have the same issue but ASG Remote Desktop is published on a terminal server so I can not delete this value.

Hi,
Yes the solution is working. We had the same problem, ASGRD is published with MS AppV v5. But we must manually remove the registry key. AppV doesn't remove the key.
Remarks: With a manual install, the key is automatically removed.

Rgds
Jonathan

Hi,

but I don't get this. The application is installed on a terminal server and the users launch ASG as a published application. Don't I need this key on my terminal server where the ASG-application is installed? This isn't a ASG-registry key.

Hi,
It's on our terminalserver that we delete this key. After that working for any users logged on this terminal.
It's indeed a key from Microsoft.
BR
Jonathan
Reply
#8
Sorry, this must be a language barrier or something. I don't get it.

First, why must I delete the registry value HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSLicensing ?

Secondly, Where would you like me to delete the registry value above? Here is my setup.

  1. One windows server 2012 R2 with terminal server installed, TerminalServer-1. This server is launching an App-V packaged ASG-Remote Desktop when users logs in to this server.
  2. The users then try and launch an RDP session inside ASG-RD to TerminalServer-2.
Reply
#9
I can't tell you why - we found that solution in MS forums...

Delete the regkey on the server where ASG-RD is installed
Regards/Gruss
Oliver
Reply
#10
(09-03-2017, 10:09 AM)DevOma Wrote: I can't tell you why - we found that solution in MS forums...

Delete the regkey on the server where ASG-RD is installed

This solved the issue.

And for those who dont know this registry value is used to license RDS on a device license basis. If you don't use this I suppose it shouldn't be a problem deleting it.

https://social.technet.microsoft.com/wik...ified.aspx

EDIT:
Thought I mention this just if someone has the same problem as me. You also have to delete any roaming profile you have on the specific user, I assume it's somewhat stuck a setting in there also.
Reply




Users browsing this thread: 1 Guest(s)