Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Windows Insider 15002 Breaks RD again
#1
Was updated last night to 15002 on the Fast Track and found I was unable to RDP to anything via ASG. I did try to replace the mstscax.dll like in the past, but no go. Running ASG 2016 9.0.5385.0. Using windows MSTSC to RDP works just fine. Experience in ASG - select RDP session and it immediately closes (no warnings, errors, notifications).
Reply
#2
Ok - I'm downloading and installing the build myself right now - will check it afterwards...
Regards/Gruss
Oliver
Reply
#3
(10-01-2017, 03:03 PM)DevOma Wrote: Ok - I'm downloading and installing the build myself right now - will check it afterwards...

Interestingly 9.0.5312.1 does not break - it works.
Reply
#4
I get the same. Immediately after 15002 I got the NLA error: The remote computer 'xxxx' requires Network Level Authentication, which your computer does not support. tried regkeys to dumb down rdp, but no luck.
Reply
#5
Same here, I also get het The remote computer requires NLA.
Yesterday it worked fine, now after install of 15002 i get this error.
Reply
#6
Yes - issue found - somewhere in the code a variable is not empty but null (only with this build) - working on a quick fix for that...
Regards/Gruss
Oliver
Reply
#7
Fix is available

http://forum.asg-rd.com/showthread.php?tid=10275
Regards/Gruss
Oliver
Reply
#8
THe patch did not fix it. I am still getting the error that this system does not support nla
Reply
#9
The first reported error war not NLA related - I missed that info and fixed only the first issue - so will have a look again today...
Regards/Gruss
Oliver
Reply
#10
Ok, MS changed again the identification processauf "NLA supported" - for a quick fix just set the old registry key on the local machine

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa - Security Packages

Add "tspkg" to the list of values - we will contact MS to clarify how it is used in the future...
Regards/Gruss
Oliver
Reply
#11
(12-01-2017, 08:46 AM)DevOma Wrote: Ok, MS changed again the identification processauf "NLA supported" - for a quick fix just set the old registry key on the local machine

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa - Security Packages

Add "tspkg" to the list of values - we will contact MS to clarify how it is used in the future...

That worked Thanks!
Reply
#12
Patch did not fix my issue - do not see an NLA message although I added the reg key anyway (still didn't work). Since the connection immediately closes, is there a log or logging I can enable to get you more data?
Reply
#13
Rolleyes 
I'm having the same issue, "The remote computer requires NLA". 

Tried the fix and the registry entry, no luck.

I'm using ASG RD 9.0.5385.1 on Windows 10 Enterprise Insider preview build 15007. It's been broken since build 15002.
Reply
#14
The registry key must work - it is part of the requirement check of our program - so we know what regkey is checked...
Regards/Gruss
Oliver
Reply
#15
(16-01-2017, 12:03 PM)DevOma Wrote: The registry key must work - it is part of the requirement check of our program - so we know what regkey is checked...

I can confirm the same (I think). Mine has both and fails to work - I too am now on 15007 and I still cannot use the program.
Reply
#16
Do you still get "NLA not supported on client" or something else??? Any entries in error log (in ASG-RD or Windows Application Event log)?
Regards/Gruss
Oliver
Reply
#17
(17-01-2017, 07:52 AM)DevOma Wrote: Do you still get "NLA not supported on client" or something else??? Any entries in error log (in ASG-RD or Windows Application Event log)?

When connecting it immediately drops - no message to the screen. The log states NLA "The remote computer 'server.bricomp.com' requires Network Level Authentication, which your computer does not support. The attached screenshot is of the registry on this computer.


Attached Files
.jpg   2017-01-17_5-56-51.jpg (Size: 369.97 KB / Downloads: 15)
Reply
#18
Try to type tspkg not in quotation marks - on my computer it looks like this

""
tspkg
Regards/Gruss
Oliver
Reply
#19
Smile 
(17-01-2017, 02:06 PM)DevOma Wrote: Try to type tspkg not in quotation marks - on my computer it looks like this

""
tspkg

And that did it. Now he question comes back to why and will it be fixed in ASG code or is it a MS fix?
Reply
#20
I'm waiting for an answer from MS? But I think we will add something that NLA is not anymore checked for newer OS - makes no sense anymore :-)
Regards/Gruss
Oliver
Reply




Users browsing this thread: 1 Guest(s)