Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ASG RD 2017 - Credentials
#1
Hi

Since the installation of ASG remote Desktop 2017, I can't use my defined credentials. That always asked for my wondows securty.

More, I lost the "Credrentials" option when I'm going in the properties of a connexion. 

Can you help me to fix this problem?

Thanks

Steve
Reply
#2
Hi Steve, sorry for the delay. Thats not usual but could happen...not often however. To your problem: what was the former version you come frome ?
Have you checked the role item for the connection where you dont see "credential" settings ? The "role" credentials must be enabled. If thats enabled do you see the credentials or is there simply "nothing" ?

Best regards,
Michael
-- michael.scholz@asg.com --
Reply
#3
(07-04-2017, 07:50 AM)Michael Scholz Wrote: Hi Steve, sorry for the delay. Thats not usual but could happen...not often however. To your problem:  what was the former version you come frome  ?
Have you checked the role item for the connection where you dont see "credential" settings ?  The "role" credentials must be enabled.  If thats enabled do you see the credentials or is there simply "nothing" ?

Best regards,
Michael

Hi Michael,

I'm having the exact same problem.
After upgrading from 2012 to 2017 i had to recreate my credentials and when i tried to add them to a connection it doesn't work.
I tried to add as default value, Inherited and Personal value, but when i double click on the connection it will always prompt for credentials.
Is there a setting that i have to check?

Regards, Meto
Reply
#4
Hi Meto,

so I assume you have added the role "credentials" otherwise you would not be able to see credentials at all. There is an option in the credetial settings "Options" - "Always prompt for password" that should not be set. You can check that if not already done.

Best regards,
Michael
-- michael.scholz@asg.com --
Reply
#5
Hi michael,

No this checkbox isn't set anywhere
Reply
#6
So you are working in file-mode or database mode ? You can choose the credentials but if you re-open the connection setting the settings is lost ? Do you use Security groups ? You say you upgraded from 2012 to 2017..hmm.. have you checked the security settings regarding the right to modify connections for the affected user in the connection tree ?
-- michael.scholz@asg.com --
Reply
#7
(09-05-2018, 08:37 AM)Michael Scholz Wrote: So you are working in file-mode or database mode ? You can choose the credentials but if you re-open the connection setting the settings is lost ?  Do you use Security groups ? You say you upgraded from 2012 to 2017..hmm.. have you checked the security settings regarding the right to modify connections for the affected user in the connection tree ?

I am working on database mode, but i don't use security groups.
I just have a few credentials, which i've assigned over the various connections.
Whenever i try to connect i'm prompted for credentials anyway
Reply
#8
Can you please create a new credentials object in Navigation - and a new connection object - add Role "Credentials" - assign your Creds and try to start your connection - is that working?
Regards/Gruss
Oliver
Reply
#9
(09-05-2018, 10:47 AM)DevOma Wrote: Can you please create a new credentials object in Navigation - and a new connection object - add Role "Credentials" - assign your Creds and try to start your connection - is that working?

I was able to migrate all connections from 2012 to 2017.
The credentials and role had to be recreated.


Just now i tried with a new connection which i made manually, assigned security role and added credentials, but same problem
Reply
#10
(09-05-2018, 12:12 PM)metodi Wrote:
(09-05-2018, 10:47 AM)DevOma Wrote: Can you please create a new credentials object in Navigation - and a new connection object - add Role "Credentials" - assign your Creds and try to start your connection - is that working?

I was able to migrate all connections from 2012 to 2017.
The credentials and role had to be recreated.


Just now i tried with a new connection which i made manually, assigned security role and added credentials, but same problem

I am having the same issue.  I actually uninstalled ASG 2017 and reinstalled version 10.1.5713.0.  It seemed to have a cache of some of my data because some of my favorites came back (but not all of them)
I created new credentials and they do not work when attempting to make a connection.
If I use Connect As Custom and manually type in my credentials, it also does not connect.  When the console comes up, I can manually type in the credentials and get logged into the server.
I have re-entered my credentials under Credential - Options several times to ensure they are correct.
It's almost acts like the credentials are not being inherited down the tree. (UPDATE - actually this seems to only be affecting a certain folder within the tree. One folder and its subcontents connect up fine)
(UPDATE #2 - we seemed to have narrowed this down to servers that have Imprivata installed on Windows 2008R2 - not sure why yet)

Thanks
Reply




Users browsing this thread: 1 Guest(s)