Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Upgrade to 2017 not working
#1
I have installed the 2017 release version.  In the environment settings I click on test database connection and it says it conencts.  But then on the environment login screen when I hit Login, It says a connection to your environment could not be established.
Reply
#2
From the caption I guess you try to upgrade from an older version!? Which one? If you use 2012 (or older) you need to create a new environment and inside the program you can choose to migrate your data from that older database (Environment=>Upgrade from 2012)
Regards/Gruss
Oliver
Reply
#3
We are using 2016 currently. Specifically 9.0.5385.0
Reply
#4
You can connect to the database with version 2016 but not when using version 2017 with the same environment/database settings? I can't believe that... there are no changes in database access...

Did you have a look into Windows Application Event Log? Any details there?
Regards/Gruss
Oliver
Reply
#5
(15-05-2017, 01:52 PM)DevOma Wrote: You can connect to the database with version 2016 but not when using version 2017 with the same environment/database settings? I can't believe that... there are no changes in database access...

Did you have a look into Windows Application Event Log? Any details there?

As I said, in the test database connection, it says it can connect.  But when I get to the environment login it says a connection cannot be established:

https://cl.ly/1g2l183o3I3E

Doesn't actually read like a database error.
Reply
#6
The "test connection" button only test the general connection availability but do not try to access any stored proc inside the database...

Again - are you really using the same login credentials / windows account for the database environment as in version 2016? Do you use windows auth for database access or Username/Pwd?
Regards/Gruss
Oliver
Reply
#7
ASG connects to a remote database over IP using SQL authentication, not windows. I've used the same creds as existing AND I made a copy of the database, created a new user for it and tried that and get the same exact thing.

I doubt it matters but on my workstation I have both 2016 and 2017 installed.
Reply
#8
Of course, for the environment login, its just using the windows user which is what I have always done:

https://cl.ly/0v2F3I3S1o3v
Reply
#9
The login dialog just "login the user" - but in the environment you have to setup the database login - that's not the same

Do you use a new database for 2017 or do you try to connect to your 2016 database? The old one would be migrated on the first logon... if you use a new one - did you really create the database within ASGRD? Because if you only specify a new (empty) database it won't work too...
Regards/Gruss
Oliver
Reply
#10
We are connecting to our existing database. We have several hundred entries in there so creating a new database from scratch is not really an option.

Yes, I know they are not the same, I've been using this product since before it was ASG. Yes, the database SHOULD convert on first use, but it is not, I am getting the errors I showed you.
Reply
#11
That's really strange - did you try to add another database environment with option "Access to an existing database" - enter again your database access information - or you could try to goto Environment Manager in version 2016 - select your environment, right click and choose "Copy to Clipboard" - then again add a new environment in 2017, choose "Connect to an existing database" and then choose "Enter encrypted database connection string"

Of course you shouldn't create a new database with all your stuff - but I need to ask to understand what exactly was done before...
Regards/Gruss
Oliver
Reply




Users browsing this thread: 1 Guest(s)