Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Mouse Cursor issue with high DPI in Remote Desktop Sessions
#1
Having issues with Mouse Cursor too small or missing in text editor applications. Is ASG aware of the issue with Windows 10 and creator update?
I have try the RoyalTS suggestion. I;m still having the problem in ASG Remote Desktop.

I'm on ASG Remote Desktop on version 2016 (9.0.5385.0)

https://support.royalapplications.com/su...p-sessions
Reply
#2
Yes it is known - and we already involved MS DEV support - it is reported to Redmond - but no feedback from Redmond yet
Regards/Gruss
Oliver
Reply
#3
(07-06-2017, 01:56 PM)DevOma Wrote: Yes it is known - and we already involved MS DEV support - it is reported to Redmond - but no feedback from Redmond yet

Hi DevOma,

Any update on this issue? I believe I am having it. This is what I see:
http://i.imgur.com/bLHXtLg.png
(the two dots in the red box are my mouse cursor)

Additionally on some servers my mouse pointer itself is tiny:
http://i.imgur.com/dhFXOoY.png

Windows 10 version 1703 build 15063.483 (creators update)
ASG 10.1.5713.0

It does not happen when I just windows remote desktop, but does happen in ASG. This also happens on a few of my co-workers PCs that are running the same versions of Windows and ASG.

Thanks,
Peter


Attached Files
.png   mouse.png (Size: 653.04 KB / Downloads: 52)
Reply
#4
Yes - one more :-)

We are still in discussion with MS - it was planned to fix it with the upcoming Fall Creators Update - but currently MS will not ensure that this will be really implemented (it is a missing/undocumented interface) - so my escalation engineer is still talking to the product group in Redmond and we hope we will get a solution asap...
Regards/Gruss
Oliver
Reply
#5
I wanted to add to this.  I am experiencing the same or similar issue.  Running Windows 10 1703, HP Zbook 15 G3 with a high resolution display.  My cursor doesn't disappear whenever I have the ASG RD on that screen, however whenever I move it to my 2nd monitor, which is only 1920x1080, the cursor will disappear whenever inside an editable field.  So inside putty, notepad, or even a field for data entry.

I also just upgraded to ASG RD 2017 (10.1.5713.0) hoping it would clear up the issue.

Thanks
Reply
#6
I'm having the same issue after updating to 1703.

Windows 10 Pro version 1703 build 15063.0
ASG remote desktop 2017 version 10.1.5713.0
Reply
#7
I found a workaround, finally! :)

My laptop screen is 1920x1080. Windows thinks 150% scaling would be best but I want it at 100% because otherwise everything is just too big. Somehow this 150% value is used by the RDP library and because the screen is set to 100% the cursor is scaled down to 66% it's original size. You can disable scaling by setting the custom scaling factor for all displays to 100%. This disables automatic scaling completely. Problem solved. Only downside is you can't set different scaling factors for multiple displays but I don't want this anyway.

Have a nice day!
Reply




Users browsing this thread: 1 Guest(s)