Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ASG 2017 Update 1 - VNC not working anymore
#1
Hi there,

today I updated to ASG 2017 Update 1. Now I cannot connect to our Igel's by using VNC. Before the update it was ok today. 

I get the message (translate from german): Unknown Error. An unknown error occured. You should restart the appication to avoid any further errors.

I restartet, but the issue persists. 

What to do? It is very important for us to connect by VNC.

Thank you in advanced.

Regards 
briloner
Reply
#2
Ah ok, I fixed it. When you enter the component check page you click on repair @ VNC. Now it is working again.

Solved.

Bye
Reply
#3
Thanks for you feedback !
Just checked it by myself to an XFCE session running X11VNC and that worked without problems. But my component check was fine. Happy that you got it working that way !

Best regards,
Michael
-- michael.scholz@asg.com --
Reply
#4
I am having the same issue. When I do a components check it shows up green, but when I try to run VNC I get:

Unhandled Exception
An unhandled error occurred in the application. You should restart the application to prevent further problems.
Reply
#5
Please run Components Check and see if the ActiveX Control is registered successfully
Regards/Gruss
Oliver
Reply
#6
Sorry, you did check that already - do you have any details from Error Log or Windows Application Event Log?
Regards/Gruss
Oliver
Reply
#7
There was nothing in the Error log in ASG and this is is what I get in the Application Log for Windows:

Unhandled Exception
An unhandled error occured in the application. You should restart the application to prevent further problems.

Unhandled Exception
An unhandled error occured in the application. You should restart the application to prevent further problems.
Exception of type 'System.Windows.Forms.AxHost+InvalidActiveXStateException' was thrown.

---------------------------

at AxViewerX.AxCSC_ViewerXControl.set_ConnectingText(String value)
at PlugInVNC.Controls.VNCClientControl.SetParamsForAxVNCClient(ConnectionParameter connParams, CredentialsParameter credParams)
at PlugInVNC.Controls.VNCClientControl.Connect(ConnectionParameter connParams, CredentialsParameter credParams)
at CloudAdminUI.DockControls.ConnectionControl.Connect(ConnectionParameter connParams)
at CloudAdminCommon.Access.ConnectionManager.Connect(ConnectionParameter connParams, IConnectionDocument& connDoc)
at CloudAdminCommon.Access.ConnectionManager.Connect(ConnectionParameter _connParams, ConnectionOptions options, IConnectionDocument& connDoc)
at CloudAdminCommon.Access.ConnectionManager.Connect(List`1 connIds, ConnectionOptions options)
at CloudAdminCommon.Access.ConnectionManager.Connect(Guid connId)
at CloudAdminCommon.PlugInBase.DoubleClick(Guid itemId, Guid nodeTypeId)
at CloudAdminCommon.Access.PlugInAccessor.ExecuteDoubleClickOnNode(Guid itemId, Guid nodeTypeId)
at CloudAdminConsole.MainForm.advTree1_DoubleClick(Object sender, EventArgs e)
at System.Windows.Forms.Control.OnDoubleClick(EventArgs e)
at DevComponents.AdvTree.AdvTree.OnDoubleClick(EventArgs e)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
Reply
#8
Seems to be a problem with the VNC-ActiveX-Control - do you use 32 or 64Bit application of ASG-RD? Do you tried to reinstall the product? If the ActiveX control is registered correctly it should work...
Regards/Gruss
Oliver
Reply
#9
I have tried both versions of the application and reinstalled both. It is happening on all three machines we have installed it on. All three are windows 10 boxes. I have only started troubleshooting issues on mine though.

Do i need to run the install as Administrator to get the control register?
Reply
#10
Normally it should be displayed in Components Check as "Failed to register" and you can re-run the command by a button.

Perhaps you can try to run it "manually" by command line - try first to unregister (perhaps an old one) and then register again

regsvr32.exe /u scvncctrl.dll
regsvr32.exe scvncctrl.dll

or for 64bit

regsvr32.exe scvncctrl64.dll
Regards/Gruss
Oliver
Reply
#11
when i run those commands I get:

The module "scvncctrl.dll" failed to load.
Make sure the binary is stored at the specified path or debug it to check for problems with the binary or dependent .DLL files.
The specified module could not be found.

Same for scvncctrl64.dll.
Reply
#12
In the meantime I also uninstalled and reinstalled the application (32 bit) with no luck.
Reply
#13
Did you run it in the installation folder of ASG-RD? Also Command Prompt should be run in Administrator mode - the 2 files should be in the install folder...
Regards/Gruss
Oliver
Reply
#14
Sorry for the delay on response, I have been off work.

That was the key I was missing. Running it from the Install Folder of the application made it work. Many thanks.
Reply




Users browsing this thread: 1 Guest(s)