Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Using Microsoft RDS gatway - hangs ASG on session exit
#1
When using the latest version of ASG remote desktop (v10.1.5630.1), and connection is going through a gateway, when closing the session ASG remote desktop hangs for 60+ seconds. This is easily repeatable. It only happens on Windows 10 x64. It does not happen on Windows 7 x64.

See attached image of how we have the configuration in ASG.

Anyone know if this is a known issue?

David


Attached Files
.jpg   gateway-configuration.jpg (Size: 104.36 KB / Downloads: 200)
Reply
#2
I'm working every day with RD-Gateway without any problems - and we didn't change the implementation of the RDP client.

Do you use the 32 or 64Bit application of ASG-RD? We know that there is an issue in 64bit app with some Windows messages but this should result in a popup error...
Regards/Gruss
Oliver
Reply
#3
(25-07-2017, 12:59 PM)DevOma Wrote: I'm working every day with RD-Gateway without any problems - and we didn't change the implementation of the RDP client.

Do you use the 32 or 64Bit application of ASG-RD? We know that there is an issue in 64bit app with some Windows messages but this should result in a popup error...

Are you suggesting I try 32bit? If so, how do I install 32bit? The download looks to be a single executable.
Reply
#4
http://forum.asg-rd.com/showthread.php?tid=10406

You can find a download link for 32 and 64 bit version here
Regards/Gruss
Oliver
Reply
#5
I have confirmed this is still a problem in both x32 and x64 release.

ASG freezes when closing connections on Windows 10 version 1607 (OS Build 14393.1378)

Not sure what else to try.

Is there any specific settings that we should set on the gateway?
Reply
#6
Update - I just tried to configure a different gateway and noticed something interesting. 

If I configure the connection in ASG to use a "fake" RD gateway (i.e. one that doesn't exist on a given server) and simply point the RD gateway setting to any server out there, it fails (as expected) but once ASG dialog appears saying the connection failed, the ASG application HANGS just like before when closing sessions using a real RD gateway. 

This indicates the ASG tool is not handling something right under any connection that is attempting to use RD gateway.

(See attached)


Attached Files
.jpg   any-server.jpg (Size: 106.17 KB / Downloads: 208)
Reply
#7
Hi,

I just tried it with Win10 Version 1607 and I set the login paramaters to "username password" and choose a credentials set. I dont use "use connection credentials" . That works flawless. Closing the RD GW connection works flawless here too without any hang in application. So it's not a common problem I assume.

Best regards,
Michael
-- michael.scholz@asg.com --
Reply
#8
I found the problem. This is definitely a code issue in ASG and here is what we found.

It appears when using ASG via RD gateway option, the ASG code attempts to connect to akamaitechnologies for some additional stuff. It fails each time and attempts to reconnect.

When we use ASG and NO RD gateway setting, we do not see ASG code attempting to connect to akamaitechnologies.

Here are some of the connects (also see attached)

a104-99-156-181.deploy.static.akamaitechnologies.com
a184-25-203-201.deploy.static.akamaitechnologies.com
a23-203-93-19.deploy.static.akamaitechnologies.com


Attached Files
.jpg   TCP-Reconnects.jpg (Size: 523.91 KB / Downloads: 178)
Reply
#9
By the way, this behavior is only seen when running on Windows 10. The ASG code behaves differently and does not have any calls to akamitechnologies from Windows 7.

Any word on what is happening here?
Reply
#10
It must be something that is configured on your servers - we use the standard MSTSC ActiveX control from MS and there is no code that tries to connect to any special addresses when diconnecting...

Did you try to use MSTSC.exe?
Regards/Gruss
Oliver
Reply
#11
Good suggestion -- when we test the Microsoft tool directly (MSTSC.exe) via gateway option enabled, and close the session, "procmon" on this process shows it also hangs in the background attempting to connect to akamaitechnologies. This must be a Windows 10 telemetry event. We have opened a case with Microsoft and will report back findings.

In the meantime, can you check to see if your environment shows "procmon" attempting to connect to akamaitechnologies as well? I suspect this will be the case, and your firewall simply lets this traffic thru, hence you don't see the issue.

Thanks,
Reply
#12
I checked with Procmon - no traffic with akamaitechnologies - it must be something in your network that is trying to contact that server...
Regards/Gruss
Oliver
Reply
#13
Update...
Opened a case with Microsoft.
Turns out the code in Windows 10 (1607) changed from Windows 10 (1511).
End result is that the client tool (mstsc.exe) on Windows 10 attempts to validate internet connection during a gateway enabled session which closes. This results in calls to Akamai (which we block from inside), causing mstsc.exe process to hang 30+ seconds. The ASG Remote Desktop process is waiting for this process to end, hence the appearance that the tool is hung.
We have been unsuccessful in getting Microsoft to recognize this as a problem - still pushing support.

(as a side note) not sure why you don't see this same behavior. We installed fresh Windows 10 builds (direct from ISO at Microsoft) and put these machines directly on outside DSL connected network, and still have this same problem, which really stems from Microsoft mstsc.exe process.
If there is any way ASG could be changed to not "wait" for the mstsc.exe process, that would obviously be another way to fix this problem.
Reply
#14
We will check that again
Regards/Gruss
Oliver
Reply
#15
I tried the following on a test system - deactivate network (IP v4) - connect via vSphere console - tried to establish a connection via RD-gateway - message appears that the RD gateway is not available - the connection closes and everything works fine - no wait
Regards/Gruss
Oliver
Reply
#16
Not sure this applies to our situation since we do not use vSphere console for connections. Can you send me screen shots of your configuration you tried? We are simply clicking "RD Gateway" and setting a value for the "servername" with "Automatic" login method and "Use connection credentials"
Reply
#17
(25-08-2017, 02:52 PM)whynotpizza Wrote: Not sure this applies to our situation since we do not use vSphere console for connections. Can you send me screen shots of your configuration you tried? We are simply clicking "RD Gateway" and setting a value for the "servername" with "Automatic" login method and "Use connection credentials"


Hello Friend, i see the same issue as you posted.

1.verified directly with mstsc.exe making a connection to  akamai cdn (23.203.61.106:80) on closing/disconnecting. In fact mstsc.exe process remains active till the network connection completes/times out.
2.akamai connections disappeared once i disabled "detect connection quality automatically" inside mstsc (experience tab).
3.Tried same with ASG 2017 (10.1.5713.0).. but ASG keeps messaging akamai cdn (or via rdp activex controls) even with "detect connection quality automatically" disabled.

My Conclusion : Since akamai cdn is not called with "detect connection quality automatically" disabled on MSTC, this is definitely a issue with ASG  remotedesktop, may be activeX controls used by ASG doesn't allow "detect connection quality automatically" to be set ???
If i close akamai connections via TCPview, ASG starts responding.
On connection closure/disconnection ASG waits till akamai connections disappear.
Reply
#18
You can configure it under Connection=>RDP=>Experience - please let me know if that fixes the issue
Regards/Gruss
Oliver
Reply
#19
(09-10-2017, 10:20 AM)DevOma Wrote: You can configure it under Connection=>RDP=>Experience - please let me know if that fixes the issue


Tried, as mentioned in my post.
Setting has no effect on connection behaviour
Reply
#20
We try to reproduce again - and check which setting is responsible for it
Regards/Gruss
Oliver
Reply




Users browsing this thread: 1 Guest(s)