Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Some RDP Connections Not Working in ASG 2017
#1
After our upgrade from ASG 2016 to ASG 2017 Patch 2 some RDP connections no longer work.

They all seem to be W2K8 R2 servers.

What happens is that after authenticating, the screen flashes, turns green and has a big "Reconnect" button in the middle of the tab screen.

I can connect to the same server in ASG 2016 and with the normal MSTSC client.

On the server I see a valid log on and an immediate log off. 

Any help would be appreciated.
Reply
#2
Please turn off the "automatic reconnect" in Settings=>Connections (at the Bottom of the list) - perhaps you can see an error message instead of the reconnect button - that could help
Regards/Gruss
Oliver
Reply
#3
(15-09-2017, 06:44 AM)DevOma Wrote: Please turn off the "automatic reconnect" in Settings=>Connections (at the Bottom of the list) - perhaps you can see an error message instead of the reconnect button - that could help

I can't find that exact setting in Connections, however everything is unchecked at the moment (and was before).

These all appear to be RDS (Terminal) Servers.  Could this have something to do with licensing not liking the new RDP client?

Until resolved we need to keep 2016 around.  I will try to get more detail on the issue for you.

PS The screen is not always green, depending on which tab it is it will change colors, but always an immediate log on/off with a reconnect button.  The actual server screen never appears, just the reconnect button.
Reply
#4
(15-09-2017, 05:23 PM)mostau Wrote:
(15-09-2017, 06:44 AM)DevOma Wrote: Please turn off the "automatic reconnect" in Settings=>Connections (at the Bottom of the list) - perhaps you can see an error message instead of the reconnect button - that could help

I can't find that exact setting in Connections, however everything is unchecked at the moment (and was before).

These all appear to be RDS (Terminal) Servers.  Could this have something to do with licensing not liking the new RDP client?

Until resolved we need to keep 2016 around.  I will try to get more detail on the issue for you.

PS The screen is not always green, depending on which tab it is it will change colors, but always an immediate log on/off with a reconnect button.  The actual server screen never appears, just the reconnect button.

We discovered that Terminal Servers appear to need the “Connect to Console” option checked

Workaround:  We modified the default RDP configuration to use this option for all RDP connections Smile
Reply
#5
(15-09-2017, 06:24 PM)mostau Wrote:
(15-09-2017, 05:23 PM)mostau Wrote:
(15-09-2017, 06:44 AM)DevOma Wrote: Please turn off the "automatic reconnect" in Settings=>Connections (at the Bottom of the list) - perhaps you can see an error message instead of the reconnect button - that could help

I can't find that exact setting in Connections, however everything is unchecked at the moment (and was before).

These all appear to be RDS (Terminal) Servers.  Could this have something to do with licensing not liking the new RDP client?

Until resolved we need to keep 2016 around.  I will try to get more detail on the issue for you.

PS The screen is not always green, depending on which tab it is it will change colors, but always an immediate log on/off with a reconnect button.  The actual server screen never appears, just the reconnect button.

We discovered that Terminal Servers appear to need the “Connect to Console” option checked

Workaround:  We modified the default RDP configuration to use this option for all RDP connections Smile

This still seems to be happening for some connections. Just downloaded Patch2 today and get [Reconnect] button in center of session window.
Did anyone come across different workarounds? Have tried the above without luck.
Thanks!
Reply
#6
forum.asg-rd.com/showthread.php?tid=10255
Regards/Gruss
Oliver
Reply




Users browsing this thread: 1 Guest(s)