Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Windows Event-ID 4005 when Using ASG
Hi folks
We are using ASG Remote Desktop 2017 (Patch2). Since two days, we cant establish RDP-Connections to Servers where the Remote Desktop Service - Server-Role is installed.
Every time we try to connect with ASG to such a server, the Application Log of the Destination-System is logging the following entry:

Log Name: Application
Event-ID: 4005
Source: Winlogon
Level: Error
Description: The Windows logon process has unexpectedly terminated.

The Problem only occurs, when we are using ASG RD as App-V-Package. With a local installed ASG RD - Session there are no problems and everything is working fine.

We surely know, there is no official support to virtualize ASG RD with App-V, but maybe other Admins are facing the same error? and a few days ago, all the systems worked fine for months! pretty strange...

Thank you for some inputs and happy new year! :-)
No experts in AppV but we always try to help :-) Did you run ASGRD 2017 Patch2 before the problem occurs? Did you install any Updates (Feature Packs) on the source or destination systems? Did you try to logon without creds and type the cres manually in the login form? We need some more details...
answers to your questions:
- yes, we already run asg2017 patch 2 before the problem occurs
- no, we didnt install any updates on the source or destination-systems
- we tried to login both (typing the cred manually or with saved cred.)
- as mentioned, we ran this configuration for months without any problems

thank you :-)
Did you try to use mstsc (as AppV package)? Same problem or not? Perhaps any prmissions? Can you force the AppV package to start ASGRD as ADMIN? Just to see if there is a difference?

I searched for the error and there are some articles in MS TechNet about corrupt W2K8 server components - but I think that's not the problem because you can use it without AppV
some good news: we just recreated the app-v-package for ASG and now its working properly (reason unknown... IT-stuff???)
we suppose some permission-issues too (maybe system-certificates etc.)
last question: does ASG use it's own RDP-Client or is it using the System-Built-In mstsc.exe?
the thread can be closed, the workaround with recreating our app-v-package will work for us. lets hope, the fix will hold for a long time...
We use the ActiveX control from mstsc - mstsc.exe is also based on that :-)

Users browsing this thread: 1 Guest(s)