Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ASG 2018 connection to SQLExpress DB
#1
Question 
Hi,

I have a SQLExpress DB setup on a server and I can connect to that DB with ASG in local mode.
I have enabled TCP/IP for that SQL DB.

When I try to connect from another computer on that DB I have an error message saying the DB does not exist. However I use the same Database name than the one used to connect locally.
Communication with the SQL express server seems OK because I get a different error message if I put a wrong database server name.
I am sure I am missing something obvious but what?

Bonus question: how do you specify the SQLExpress port number in the database server field. For the moment I use the default port 1433 but for security I will use a different port number later on? server:portnb does not seems to work.


remote connexion parameters

local connexion parameters
Reply
#2
Hi,

I can see if you use the correct server name? Perhaps you have used an instance name too? Like Servername\SQLExpress? If you have TCP/IP enabled and your firewall allows connections to your server it should work - did you check that the user you are using is allowed to access the database?

And port number can be specified by using SERVERNAMEToungueORT - why should it not work?
Regards/Gruss
Oliver
Reply
#3
(14-02-2018, 08:43 AM)DevOma Wrote: Hi,

I can see if you use the correct server name? Perhaps you have used an instance name too? Like Servername\SQLExpress? If you have TCP/IP enabled and your firewall allows connections to your server it should work - did you check that the user you are using is allowed to access the database?

And port number can be specified by using SERVERNAMEToungueORT - why should it not work?

I found out what my mistake was. When creating the sqlexpress db with ASG a user sa is created for the database I had to use that user to define the connexion to the DB and not the user setup in asg security groups.

Thanks for your help
Reply




Users browsing this thread: 1 Guest(s)