Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
External Program / RunAs
#1
Hi,

I use ASG 2017 Patch 2 and want to start the Internet Explorer with a given URL as Admin-User.
So I have defined the Internet Explorer ("C:\Program Files (x86)\Internet Explorer\iexplore.exe") as "External Application". 
When I try to connect as Admin-User the Internet Explorer starts with the correct page as Loggedin-User.

Any hints?

Regards

Roberto
Reply
#2
Perhaps it depends on the app - if I try it with IE and "Start as" nothing happens at all - but if I run cmd.exe and "Start as" I can see in TaskManager that cmd.exe runs as the user I have selected...
Regards/Gruss
Oliver
Reply
#3
(25-04-2018, 01:22 PM)Hi Oliver,I tried with cmd.exe. The command whoami shows the Loggedin-User, not der Admin-User I selected. So I finally tried to connect "As Userdefined" entering the credential manually with the same result.Thanks for trying. Any further hints or ideas?  Roberto Wrote: Perhaps it depends on the app - if I try it with IE and "Start as" nothing happens at all - but if I run cmd.exe and "Start as" I can see in TaskManager that cmd.exe runs as the user I have selected...
Reply
#4
How do you start the app? Right click the app and choose "Start as" - on my machine it shows the right user with "whoami" and also in TaskManager (Details view)
Regards/Gruss
Oliver
Reply
#5
(25-04-2018, 01:50 PM)Hi Oliver. Intersting. When I start the Applikacation directly under "External Application" it works. When I define a new connection and start with "Connect with Options" then it does not work. (Connect witt protocol = Ext. App. , Conect As = Admin User, View as = Fullscreen) Wrote: How do you start the app? Right click the app and choose "Start as" - on my machine it shows the right user with "whoami" and also in TaskManager (Details view)
Reply
#6
Ok, I think we fixed that already in a newer version than you are using - because if I try that with ASGRD 2018 it works as it should...
Regards/Gruss
Oliver
Reply
#7
(27-04-2018, 08:04 AM)Oliver, I tried today with ASGRD2018_Patch3. Same problem. Wrote: Ok, I think we fixed that already in a newer version than you are using - because if I try that with ASGRD 2018 it works as it should...
Reply
#8
What exactly are you doing? Your last description was 3 different options that you can't choose in context menu at the same time?!? Did you try the same as I told you? Configure Ext App, create a connection from type ExtApp, choose the ext app in properties of connection and then try to start the connection by right click "Connect as=>Admin user"

I need all the steps you are doing to verify the functionality...
Regards/Gruss
Oliver
Reply




Users browsing this thread: 1 Guest(s)