Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ASG RD 2018 connection fail
#1
Hello, I upgraded ASG RD to 2018 with SQL server 2016 in my company.
After upgrade, there are some users cannot connect to database environment.
The authorization is by AD group,  set in "Security Groups".
I have checked that user's AD account in "User account"
Could you give me a hand, how to trouble shooting this problem?
Thank you.
Reply
#2
Which error message the users get?
Regards/Gruss
Oliver
Reply
#3

.png   error.png (Size: 8.09 KB / Downloads: 7)
.jpg   permission.jpg (Size: 65.82 KB / Downloads: 4)

Please see 2 screenshot, one is error when test connection, another is user list.
Thanks.
Reply
#4
It's the permission in SQL server - see help file for necessary permissions on SQL Server

Working with environments=>Working in database mode=>Necessary permissions on SQL server instance
Regards/Gruss
Oliver
Reply
#5
Hello, Oliver,

these 2 screenshot are correct?


.png   SQL permission 1.png (Size: 60.9 KB / Downloads: 2)
.png   SQL permission 2.png (Size: 59.53 KB / Downloads: 2)
Reply
#6
Yes - now you have to check if the user is assigned to this group and have access to the server
Regards/Gruss
Oliver
Reply
#7
Hello, Oliver,
After Database permission setting, now user can login ASG RD 2018.

But it's strange that there is no "Connections" for normal users, although I have enabled any permission for user group.
Could you see what's wrong?

.png   User no connection.png (Size: 46.2 KB / Downloads: 4)
Reply
#8
Check the permissions on "Connections" - goto Properties => Security
Regards/Gruss
Oliver
Reply
#9
This screenshot?

.png   2018-05-17_14-06-17.png (Size: 46.91 KB / Downloads: 4)

By the way, there is one user still not able to pass "Test connection"
even "Security Group" disabled, and "select" "execute" & "select" enabled for public in SQL server
Reply
#10
Yes - you need to add security groups or add your users to Administrator group

If "Test connection" fails the user can't access the sql server / database - it's network / security related!
Regards/Gruss
Oliver
Reply
#11
Sorry, Oliver.
You mean if i enable "Security Groups" by "active user permissions", then only users in "Administrators" can work normally?
Reply
#12
In your screenshot there is only the Administrators group assigned - so only assigned users to this group are allowed on this item (and sub items) - you can Add security groups and set permissions on each object (or inherit to child objects by default) - you need to login as Admin to set these permissions on object level...
Regards/Gruss
Oliver
Reply




Users browsing this thread: 1 Guest(s)