Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Data file Damaged after upgrade from 2012 to 2018
#1
Hello,
When I start 2018 the first time, it let's me import the settings from 2012 and works in the initial session.  As soon as I stop and restart the program I get the message that my settings are damaged.
When I use backup then environment is empty.
The same situation is when I use 2017 version.
I am using local file with windows logon protection. I have in my settings around 4.000 connections and i do not want it to create manually again Smile
Version 2012 work fine.

Do you have any tool that I can use to detect what is wrong?
Reply
#2
Hi,

normally that should be no problem even in file mode. Ho did you do the upgrade ? It's important to use the upgrade wizard to import the 2012 data into ASG-RD 2017 or 2018 ! That way there could be no damage to the data file because it will be just read not written or modified in any way.
So the first thing after installing ASG-RD 2018 is to create an environment that is similar to the old one you want to import: here create a filebased environment with Environment Manager ( main menu "Environment" -> Environment Manager ) with the same encryption type. Then you got a new clean 2018 environment. Now again use the main menu "Environment" -> "Upgrade of 2012 environment".
Here choose the first option "Choose environment from old configfile" click "next" and VERIFY the path to the configfile ( for example: C:\Users\your.username\AppData\Roaming\visionapp\vRD 2012\vRD.config )
and choose from the pull down menu the environment ( possibly "stabdard" ), then proceed. This way the old filebased db will be imported correctly into 2018.

Hope that helps,
best regards,
Michael
-- michael.scholz@asg.com --
Reply
#3
Hi, I did upgrade as you wrote in your post before I open this thread.
I also try to make upgrade from 2012 to 2018 and export DB in to the RDE file. Then create new environment and do import, but this end with error. (Unhandled Exception)
Reply
#4
Hi Lumir,

What post do you mean "before" that thread ? You can't import files from 2012 directly to 2018 by using an rde ( export) file. The only way is to use the upgrade wizard described above or you could use a csv export of connections but the you may have to adjust import settings and loose credentials. But the "normal" way using the wizard should work flawless. Its very important to start 2018 with a NEW and empty Environment. Then import the old environment by using "Upgrade of 2012 environment" in the "Environment" menu. Is it that what you did ? If thats done you can also start the "Data optimizer" in the main menu "Administration" to check the data structure. Have you tried that ?

Best regards,
Michael
-- michael.scholz@asg.com --
Reply
#5
Hi Michael,
What I mean of "before" creating of this thread is that I did exactly the steps that you described in your post.
I also now started the data optimizer and fix all what it found, then I close the application and start again, but it does not help. Still the same error "Data file damaged".
Reply
#6
Thats really strange,

so you still have the working 2012 environment ? What kind of version is it exactly ? We advise to use the latest 2012 version..that should be Patch8. Can you verify the version number ? Should be 7.3.4144.0. If you have an older version maybe an update to 2012P8 would help. But you should make a backup of the database before ! I would offer you to try the upgrade for you if you could provide the database - we would need it anyway to see whats going wrong if we dont get around it. Hmm...do you have any error logs in 2018 when you restart ? maybe they give us a hint... ( Activate the logs before in "Tools"-"Settings"-"Environment"-"Logs" and restrict the days and entries !)

best regards,
Michael
-- michael.scholz@asg.com --
Reply
#7
Version is 7.2.3913.0
Reply
#8
Ok you use Patch5, so I would suggest installing version 2012P8 first. Normally nothing bad should happen but I would also suggest to do a backup of the SQL database before doing anyting.
Get the program version here: https://d2l2g77p7dyozs.cloudfront.net/ASG-RD2012_P8.zip. You can use the 2018 license if your old 2012 license is not adequat for use with 2012P8.
If 2012 works fine then you could again try to import that database by the Migration Wizard of ASG-RD2018.

Best regards,
Michael
-- michael.scholz@asg.com --
Reply




Users browsing this thread: 1 Guest(s)