Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ASG RD 2018 requires Network Level Authentication
Hello, my ASG RD 2018 cannot connect some Windows Server 2012 R2, while direct RDP (mstsc) works.
With this error: The remote computer '******' requires Network Level Authentication, which is not enabled in the RDP connection properties.

.png   2018-06-27_14-21-45.png (Size: 179.95 KB / Downloads: 8)

Disable "Network Level Auth" when client OS is Win8 or higher - this option is chosen.

.png   2018-06-27_14-34-13.png (Size: 15.04 KB / Downloads: 5)

which exact version are you using ? Normally that error should not occur since a fix is already implemented. There is a manual fix for that "problem" that should not be needed any more ( ) so that could be a quick workaround. And you already verified the correct setting as shown on your screenshot. What makes me wonder is that only some servers are affected so I assume they differ in some way to the working servers. What about udates on theses servers ?

best regards,
-- --
Hello, my PC is Windows 10 Enterprise.

Version 1703 (15063.1088)

Server is Windows Server 2012 R2 standard.

Version 6.3 (Build 9600)

ASG RD 2018 ver 11.0.5924.0
Thanks for your feedback,

hmm.. unfortunately my oldest Win10 is version 1709 and I tested that to connect to Win 2012R2 Server - Build 9600 - without any problems. And I used ASG-RD 2018P3 ( your version) also... no probs. So the only difference is the version of Windows 10. Is your Windows 2012 Server configured as a Remote Desktop Gateway ? Because Version 1703 of Windows 10 breaks RDP connectivitiy with RD GW servers and has issues with RDP. There are reports of people downgrading or upgrading to prevent those connectivity problems. Can't test it right now because I just have Windows 10 build 1709 and 1803 . Please see that link

best regards,
-- --

Users browsing this thread: 1 Guest(s)