ASG-RD 2015 RTM
#21
No, 2015 is installed into a separate folder, 2012 will still work when 2015 is installed. You can migration your data from 2012 -> 2015, after this you can uninstall 2012
Reply
#22
Thanks Andreas
I have installed 2015 alongside 2012 and I have configured the details to my existing Database and the 'TEST CONNECTION' returns a positive result, however when I now click the 'NEXT' button i get the following error.

Connection could not be established
Could not find the stored procedure 'connection test'
Reply
#23
You need to create a new database - after that you can migrate your data from the old one
Regards/Gruss
Oliver
Reply
#24
Im now getting the following error (this has been reported in the 2014 RC5 release but there was no definitive answer..

We're experiencing crashes of RC5 when people try to initiate remote desktop connections:

From the error log:
An error occured on executing an sql statement
LogsAdd
There is already an open DataReader associated with this Command which must be closed first.

---------------------------

at System.Data.SqlClient.SqlInternalConnectionTds.ValidateConnectionForExecute(SqlC​ommand command)
at System.Data.SqlClient.SqlConnection.ValidateConnectionForExecute(String method, SqlCommand command)
at System.Data.SqlClient.SqlCommand.ValidateCommand(String method, Boolean async)
at System.Data.SqlClient.SqlCommand.InternalExecuteNonQuery(TaskCompletionSource`1 completion, String methodName, Boolean sendToPipe, Int32 timeout, Boolean asyncWrite)
at System.Data.SqlClient.SqlCommand.ExecuteNonQuery()
at CloudAdminDataAccess.SqlDataAccessor.LogsAdd(LogItem logItem)

this causes the application to crash
Reply
#25
Are you using RTM or RC5?
Regards/Gruss
Oliver
Reply
#26
Oliver
We are using RTM 2015 and we have resolved the problem. The installation created two tables LOGS & ITEMPROPERTIESUSAGE were created under the local USER Schema and not DBO, we changed that to DBO and the migration worked OK.
Thanks
Reply
#27
No you can run it side by side
Regards/Gruss
Oliver
Reply
#28
Which parameter / command line option do I have to use (in database mode) to login directly without the prompt for the "Login to..." screen?

I already use the ASGRD.exe /instance:ASGRD /loginintegrated:true Command line options

But still the screen for my users, where the have to press to Login button. I guess in the past the /loginintegrated fixed this. Now the /loginintegrated disappears...


Also another question reqarding the permissions.

I have multiple folders under the Connections Tree item. But I want to control which Security Groups sees which connections folder. After migration from 2012 version, I had no connections visible. After assigning the Standard Read option to a Security Group; these users see all the connections Folders... I want only that some specific folders are visible for them. How to archive that?


And 3th question:
I want centrally manage which options/settings are configured for my users. How to archive that? Which file I have to get as template (where is it located) and which command line option I have to use?

Now the options are grade out for my users; but the settings are not configured centrally (so the are configured wrong).
Reply
#29
We missed that command line parameter in QA - will be fixed for the first patch!

Permissions - all users need at least ReadOnly on the root folder - and then you have to choose on level1 which users are allowed to see more folders - default is "Inherit" - so you have to switch to "Default" and assign the right permission groups

Settings can now be managed by Admin - if you want your users to change the given default settings you can set Prmission for that - select the Security Group => Details => Settings => Allow changing user specific data
Regards/Gruss
Oliver
Reply
#30
(26-11-2014, 11:29 AM)DevOma Wrote: Can you give me at least a screenshot - perhaps I can see something...

Hi,

It has to do with the navigation pane, if i have it to hide it wont work with delete, if it is in SHOW all the time i can delete.


Next PROBLEM, i cant sync with VMware Vcenter, when i press sync after 10 sec it says an error occurred while reading data from VMware host. Operation cancelled.

Object of type ´DistrubutedVirtualPortgroup´With ID ´dvportgroup-5567´not found in vCenter Server.

We dont have o SWitch by that name.

Please help ASAP

// Kristoffer
Reply
#31
Ok, thanks for the info - I changed already the code for checking the DELETE-command - how do you want delete if you are not in the navigation? In my understanding you have to select an entry in the navigation tree first and then you can delete - I found constellations where the control returned a wrong active window and I replaced that code (if I docked Navigation as Document and put it back to the left and I couldn't delete too)

The VMware error will be checked asap - I forwarded it to the right developer and hope I will have a solution asap.

I think next week will the first fixes be available :-)
Regards/Gruss
Oliver
Reply
#32
Looking forward to the first patch! For the /loginintegrated command line switch.

I figured it out with the permissions: thanks!

About the settings; so I don't have to specify the /ProfileFile anymore; because it's configured by the administrator? Nice!

Question about licensing: Is this named or concurrent? And can I view my current usage? Receive users a message when the license limit is reached?


Another question about this new version:

My ASG RD users usually type in (the first part of) the servername in the tree to select the right server. in ASGRD2015 the selection go's to the server that's starting with the next character; eg: SERVER > first server with S selected, then E, R etc.

Can this be configured by a setting? Or can you fix this in next patch?
Reply
#33
(25-11-2014, 11:09 PM)DevOma Wrote: I got your license and you will get answer tomorrow-sorry for the "standard reply" :-)

Hi,

Have you had any luck with the license?

regards,

Damian
Reply
#34
Found more bugs,

Sometimes it wont take your local drives with you in RDP, and yes i have selected in properties that it should.

// Kristoffer
Reply
#35
Can you add a button for a drop-down menu in the right upper corner near my tabs, if I have more connections/tabs than can fit in my screen?

That would be nice!
Reply
#36
Kristoffer , do you have a detailed error in your application event log or error log inside the application?
Regards/Gruss
Oliver
Reply
#37
I upgraded/imported my vRD 2012 database with around 1000 connections.

In/since RD2015 I get on many connections the error 'Unhandeld Expection' "An unhandled error occured in the application. You should restart the application to prevent further problems." when I try to connect them. My colleagues also get the same error on the same connections.

It looks like that all connections with issues where connected (or maybe in a saved session?), at the time I took a upgrade of 2012 / backup/import.

I have to delete and recreate the connections (with the same settings), to work-around this.

Please fix this (with an sql query, or patch please).
Reply
#38
(27-11-2014, 03:16 PM)DevOma Wrote: Kristoffer , do you have a detailed error in your application event log or error log inside the application?

Hi,

No details what so ever.

// Kristoffer

Hi Again,

Next problem, I have a CSV file with all my Linux servers, iam trying to import those. but it wont work. What is it looking for in the excel?

It wont populate anything.

// Kristoffer
Reply
#39
@Kristoffer: The format has changed from 2012 to 2015 - it is described in the online help - you now can specify the fields to import with your csv - if you make an export you wiill see - you can specify the columns in export - on import it will be read from the file which columns are in the csv and only these columns are used for the import
Regards/Gruss
Oliver
Reply
#40
@hardinxcore: Do you get the error "while you are importing or migrating" your data - or do you get errors on all conneections after migrating?
Regards/Gruss
Oliver
Reply




Users browsing this thread: 1 Guest(s)