Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Keyboard Menu Key
#1
When I press the Menu key on the keyboard while in a RDP session, both a menu for ASG and for the RDP host show up. See the attached screenshot. Arrow keys will navigate the menu in the RDP host and not the ASG menu. Same for escape (closes the RDP host menu). The only way I've found to remove the ASG menu that pops up is the select one of the options with the mouse or click outside to another open window / desktop.
Expected behavior would be to only show the right click menu for the RDP host (as this is where focus is) seeing as how that's what the arrows / escape key work with.

On another note, if the focus is on a search result for a connection and I press the menu key, nothing happens (it does work in the text box). However, if the focus is on a connection in the navigation tree, it brings up the menu as expected.
Expected behavior would be to show the menu in the find items pane as well. Ideally, I'd like to type in search text, press tab to the results, navigate results with arrow, press menu key on selected to take action on that connection.

http://en.wikipedia.org/wiki/Menu_key


Attached Files
.png   ContextMenuKey.png (Size: 16.42 KB / Downloads: 6)
Reply
#2
How did you configure your rdp session? Under RDP=>Resources - in my case it is working as it is configured - so windows keys are executing on remote or local machine...
Regards/Gruss
Oliver
Reply
#3
I've tried all of the options for in full screen only, on remote computer, local computer. Get the same result 99.9% of time time.
What's interesting, this morning while testing, I was able to press the menu key 10-15 times and have the ASG menu not pop up as well. However, once I switched to a different connection, the issue came back. Switching back to the original connection that allowed me to press the menu key without issue started again.
It looks like somehow focus is not always getting released from the ASG app/tab bar when clicking inside the RDP session.

If I double click on the tab and pop out the connection to it's own window, I'm unable to reproduce and works as expected.
Reply
#4
I to am experiencing this issue, if i have local computer selected and push the context menu key, the menu appears on both local and remote.
Reply
#5
I will check as soon as I can...
Regards/Gruss
Oliver
Reply
#6
I have the same issue and remember having found a way to turn it off for v2012. I haven't been able to find that thread on here, but at least I can say that it was possible to turn off the menu shortcut functionality with the 2012 version
Reply
#7
(10-06-2015, 05:00 PM)mikeyuen Wrote: I have the same issue and remember having found a way to turn it off for v2012. I haven't been able to find that thread on here, but at least I can say that it was possible to turn off the menu shortcut functionality with the 2012 version

I had the same issue too with 2012 and found a way to turn that off in one of the Forum threads here too. But I can't find that solution any more.

Following this thread.
Reply




Users browsing this thread: 1 Guest(s)