Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Unattended auth popup when using quick connect
Hi all,

I am currently facing a strange issue since few days.
This has started to occur after activating the disk mapping in RDP ressource part (clicking on Use full connection properties button of quick connect box with correct Credentials selected)
Disk Resource mapping is working fine but now if I don't click on "Use full connection properties" button before clicking on connect, then I am getting a windows security window opening requesting for credentials.
If I just click on the full connection properties button before connecting (even with changing anything) then it connects with no issue.
Working fine also when not using quick connect and right clicking on the computer name in the left pane and connecting as with the correct credentials. 

It is user related as if I use another user to log in ASG then quick connect is working correctly as before.
It looks like a bug but or an issue inside by ASG user profile but I don't really find a way to get rid of it.

Any idea?
did someone has seen this kind of behavior also ? 

The user I can see in the windows security box (asking for pwd) is the one with which I launch the ASG client.
it is like the quick connect don't use the credential recorded in the DB.
Same thing if I change the credentials selected
but it is using them correctly if I click first on use full properties button.
weird Sad 

Many thanks


Attached Files Thumbnail(s)
Are you using a database environment or local file as data source?
(12-11-2020, 11:30 AM)DevOma Wrote: Are you using a database environment or local file as data source?

Hi Oliver,

A database environment
We are trying to reproduce your issue - currently without success - but still try :-)

Do you have tried with different credentials - just for testing? It must be something special because nobody else reported this problem before

Occurs this issue only if you select an server entry from history list? Or just if you type a new server name? You have described a lot in detail - but something must be different :-)
yes I ve tried with multiple credentials I have and same thing.
But that's occurring only for this user I am logging to ASG with. I ve tried to log to ASG with another one and it works fine. So not sure if this will be easily reproducible as seems to be related to this user only.
This problem occurs either when I use a server from the history list or if I type a new server name in the filed directly.

What is making me crazy about is the fact that if I click on the buttong "Use full connection properties" then I click on the connect button without changing anything, it works. :s
Did you try to "Tools=>Reset quick connect history"? Perhaps some wrong data will be removed also? Just if you not really need to keep your history :-)
(12-11-2020, 03:35 PM)DevOma Wrote: Did you try to "Tools=>Reset quick connect history"? Perhaps some wrong data will be removed also? Just if you not really need to keep your history :-)

Yep I ve tried that already but with no luck
still the same Sad
Strange is that it only happens for one user - I have found an issue regarding QuickConnect but that couldn't be the solution - data in Full Connection Properties should be saved for each user (I guess in local mode it works, but it database mode it was removed with every restart of the app) - I fixed that issue - but as it will be removed it could not cause the issue you have - still looking on it but right now not really an idea what could be the difference
I think that maybe I will have to delete my account from the DB and get it recreated.
Is there a way and what would be the process for that ?
we are using SSO
You should backup your database - if it will not help you can restore it :-)

Then Tools=>User Accounts - there you can choose your account and delete it!
Update on this case.
So I ve try to use my other user and the same thing is appearing also.
I ve checked disk in ressources and now I ve got the same behavior.
When trying to connect it always asking me for another user credentials through a windows security window.
If I uncheck disks in resources still having the same security credential window opening Sad
if I expand the full connection properties then it is fine to connect, and if I right click a server listed on the left pane and connect from that using a credential, then no prob also.
so the exact same issue than for the other user :s
I will ask to my colleagues to do some test also to see if we can reproduce also on another user

2nd update
exporting my credentials, deleting them and reimporting seems to solve the issue.
I will do some more test again and let u know

Do you think we should update our version ?
I tried so many times to reproduce - but I can't - but if you say after deleting and reimporting the creds it works it should be something with your cred data - even if I don't understand why...

We didn't change anything on the RDP client interface in the last versions - don't know which version do you use currently - you can give it a try with a newer version - but if the reimport of creds is working for you that might be also a solution?!?
Hi Oliver,
My colleague Dewey which is managing this app, will work next weekend on updating to the last version.
I ve done some test with a colleague and changing RDP resources disk access seems to generate a similar issue for him also.
I am now waiting for the update and will do some new test then and will keep you informed of the result


Users browsing this thread: 2 Guest(s)