Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Connect to Windows Server 2016 RDS loadbalanced farm
#21
(01-08-2019, 01:05 PM)DevOma Wrote: Sorry, not yet - will try to go on with this issue asap….

Hi,

I am also using RDS broker and RDS gateway in RDS farm and I would like to use ASG for access. Is there any progress how to define connection to Remote Desktop behind RDS Broker?
Reply
#22
No, currently not - I'm sorry...
Regards/Gruss
Oliver
Reply
#23
Hi,

It is working for me. The Remote Desktops can be add to ASG. Remote Apps seems not working for me.

Load balancer info: tsv://MS Terminal Services Plugin.1.{Remote Desktop name} - it is part of rdp file which can be downloaded from rds web page.
Reply
#24
Has anybody got this working with a 2019 RDS farm?

I've been testing it and I can get it working with our 2019 brokers and the farms that run 2012 R2 RDS Session hosts, but none of our farms that have 2019 RDS session hosts work.

I just get the following error in the RDS broker logs:

Farm name specified in user's RDP file (hints) could not be found.
Error: The farm specified for the connection is not present.

This is misleading as the farm name is definitely correct (copied out of both the RDP file and directly out of the broker SQL database in exactly the same way as the 2012 R2 farms) and I've tried with multiple farms (In case it didn't like something in the name).

All 2012 R2 session host farms work fine, all 2019 farms give the error above, on the same 2019 broker.

I'm guessing there's been some change in 2019 RDS that means it's just not parsing the farm name correctly.
Reply
#25
*bump*

Anybody?
Reply
#26
Currently not tested - I can add it to my ToDo-List and will see how and when I could deploy RDS 2019 farm for testing...
Regards/Gruss
Oliver
Reply
#27
(15-07-2020, 08:49 AM)DevOma Wrote: Currently not tested - I can add it to my ToDo-List and will see how and when I could deploy RDS 2019 farm for testing...

Thanks, just want to check I'm not going mad.

I've done some further testing with another 2019 broker and it's the same as the other, 2012 RDS session host collections work fine but 2019 RDS session host collections don't.
Reply
#28
(15-07-2020, 09:57 AM)a1ex Wrote:
(15-07-2020, 08:49 AM)DevOma Wrote: Currently not tested - I can add it to my ToDo-List and will see how and when I could deploy RDS 2019 farm for testing...

Thanks, just want to check I'm not going mad.

I've done some further testing with another 2019 broker and it's the same as the other, 2012 RDS session host collections work fine but 2019 RDS session host collections don't.

*bump*

I've checked with patch5 and the issue is still not fixed.
Reply
#29
Just to update you - we now have a test environment - same issue in our environment - we try to find a solution...
Regards/Gruss
Oliver
Reply
#30
Excellent, thanks.

If you need any testers please get in touch.
Reply
#31
I think I found the reason - first, please check your data for the load balancer property - if you have used the Import of Rdp-Files it might have cut the tsv: in front of the value - so ensure the value is equal to the value in original rdp file

Then try to set "Connect to Console" in RDP properties - it seems that this is necessary for connecting to RDS 2019 farms... In our environment that makes the difference!!!
Regards/Gruss
Oliver
Reply
#32
Hi,

I tried both of those suggestions a few months ago I'm afraid, I've just given it another try and it still doesn't work.

I've confirmed that I'm including the "tsv://" bit, this is my full string:

"tsv://MS Terminal Services Plugin.1.AX_Technology"

If I swap the collection name after "tsv://MS Terminal Services Plugin.1." to another collection that uses 2012 R2 session hosts it works fine, changing to point at a different collection with 2019 RDS session hosts (we have multiple collections) breaks.

We have multiple RDS brokers (All running 2019), it's only if the RDS session hosts in a collection are running 2019 that it doesn't work.

I've also tried with "Connect to Console" checked in ASG and it makes no difference whether it's checked or not, I get the same error (RDP protocol error).

Kind Regards,

Alex
Reply
#33
Do you get an RDP error code in ASGRD?
Regards/Gruss
Oliver
Reply
#34
I get prompted for my creds and then it flashes "Disconnected" and the screen closes.

I then see the following in the RDS broker:

RD Connection Broker received connection request for user EXAMPLE\alex. 
Hints in the RDP file (TSV URL) = tsv://MS Terminal Services Plugin.1.AX_Technology 
Initial Application = NULL
Call came from Redirector Server = axt-man-rd10.example.net
Redirector is configured as Virtual machine redirector


Followed by:

RD Connection Broker failed to process the connection request for user EXAMPLE\alex.
Farm name specified in user's RDP file (hints) could not be found.
Error: The farm specified for the connection is not present.


Yet if I change the ASG entry to point at a 2012 farm (Changing nothing but the load balancer info field) on the same broker it works fine.

I'm taking the load balancer info direct from an RDP file (Which works fine regardless of OS) so it must be something in the way the hint is passed in ASG that is causing the issue.

What's strange is that it's the RDS broker that is reporting the issue but it must be something to do with the collection as it's only affecting collections with 2019 RDS servers.
Reply
#35
Sorry, I think the "Connect to console" was working in our test environment because we have most on one server - so it just connects to this server and ignores the LoadBalancerInfo - we can see the same error in Logs as you do - so we will continue trying to find a solution :-)
Regards/Gruss
Oliver
Reply
#36
(17-12-2020, 01:54 PM)DevOma Wrote: Sorry, I think the "Connect to console" was working in our test environment because we have most on one server - so it just connects to this server and ignores the LoadBalancerInfo - we can see the same error in Logs as you do - so we will continue trying to find a solution :-)

It would be really great if there was a solution to this problem. Unfortunately, there has been no real progress here for years. Can we expect a solution soon or are there no plans to fix the bug.
Reply
#37
We tried to find any difference between 2012 and 2016 farms - analyzed the data that is send - and tried different settings - without any result - I'm sorry, currently we have no solution and don't know how to fix it
Regards/Gruss
Oliver
Reply
#38
Hi, is still not possible to connect via RDS loadbalancer (RDS Connection Broker)? Thanks, Nico
Reply
#39
Sorry, we didn't find the difference and stopped working on that issue...
Regards/Gruss
Oliver
Reply
#40
Sorry, I imported our RDP-File and it works, thanks!
Reply




Users browsing this thread: 2 Guest(s)