Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Connect to Windows Server 2016 RDS loadbalanced farm
#41
(11-02-2022, 04:41 PM)DevOma Wrote: Sorry, we didn't find the difference and stopped working on that issue...

But it is really working without problems on our 2016er RDS Farm... sorry I saw you are answer after my post!
Reply
#42
Hi,

Any news on this issue ?

Like others I was able to make "load balance info" work on 2012R2 RDS farms. But on 2016 RDS farms it is not working for me. The error log was :

Log Name: Microsoft-Windows-TerminalServices-SessionBroker/Admin
Source: Microsoft-Windows-TerminalServices-SessionBroker
Date: 10/26/2022 3:06:18 PM
Event ID: 802
Task Category: RD Connection Broker processes connection request
Level: Error
Keywords:
User: NETWORK SERVICE
Computer: BROKER.domain.com
Description:
RD Connection Broker failed to process the connection request for user DOMAIN\Username.
Farm name specified in user's RDP file (hints) could not be found.
Error: The farm specified for the connection is not present.

Outside of ASG-RD connexion work fine with the same load balance info. It's really annoying in our client context with a lot of 2016/2019 complex RDS farms (many RDSH, RD Broker, RD Gateway...).

@eisback let us know how you make it work ?

Our environnement :
ASG-RD 2022 with patch 6 installed on a Windows Server 2019 VM.

Thanks
Reply
#43
Hi,

After a lot of tests, I finally understand which cause this problem. I realised that all ours Windows 2016/2019 RDS collection contain a "-" in its name.

After removing this "-" on a test environnement connection with loadbalanceinfo work fine !

I did other tests and there is the first results :
- RDS collection name with "-" or "_" like "RDS-TEST" or "RDS_TEST" --> connection not OK
- RDS collection name with "-" or "_" but with number at the end like "RDS-TEST1" or "RDS_TEST1" --> connection OK strangely
- RDS collection name simple like "RDSTEST" --> connection OK

Issue is the same on Windows 2012R2/2016/2019 RDS farms.

There is a big impact of renaming all of ours RDS collections because of client terminals side impact.

@DevTeam : it's seems like a parsing problem of the loadbalanceinfo field. Could you take a look to patch this please ?

Thanks
Reply
#44
The problem is that this feature is not really documented in any MS documentation - we found only that the length of the LoadBalancer-Field makes a difference - need to add a blank if it's odd length - don't know why - it's great to see your info about different characters work or even not work - give me some time and I will try to implement some different ways how this handled for testing - I have currently no RDS farm for testing - perhaps we can setup one for better testing - thanks for sharing your testing results! This might help to find a solution
Regards/Gruss
Oliver
Reply
#45
We ran into the same problem when implementing the MstscAx libs into our software, and it took a few nerve-wracking days to find a workaround for this. As Oliver mentioned, the documentation for tsv load balancing values is near non-existent.

@Oliver:
I made a post about this on StackOverflow a few days ago and just described my solution there, which can be implemented nicely in your PlugInRDP library. Just be aware that the load balancing info can also look different than the tsv uris that are discussed here, see this post on Microsoft Learn.

@Fellow ASG users
Until the solution is tested and implemented, you can manually add a second dot to your load balancing info if the collection name consists of an odd number of characters.

Examples:
'tsv://MS Terminal Services Plugin.1.even' -> 'tsv://MS Terminal Services Plugin.1.even'
'tsv://MS Terminal Services Plugin.1.odd' -> 'tsv://MS Terminal Services Plugin.1..odd'
Reply
#46
Wow - really nice - we have tried also so much different ways how to set this property - and nothing could be found in any documentation! Changes are done in code!
Regards/Gruss
Oliver
Reply




Users browsing this thread: 2 Guest(s)