Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
KeePass Issue with Masterkey

when I add a Keepass file for my accounts, its working till I choose the entry in Keepass file for the Keepass password (sounds still wired) 
Then ASG is crashing. Without the Masterkey its working

ASG Version 12.0.6504.1
KeePass: 2.43
Windows: 1809
I don't really understand - you have a Keypass database file - you have configured a sync in ASGRD - you can sync the data from KeePass to ASGRD

Where to you choose the entry that is causing the crash? If you select credentials for a connection? How did you set the sync options "Sync only object names" or "Sync all data"???

  1. Added KeePass file for the credentials without Master Password
  2. Run "Sync Now" => works
  3. Right click to a connection and log in with an account from KeePass => works, but I will be asked for the Master Password
  4. Select properties from the KeePass entry 
  5. Check "Master Password" and choose the KeePass entry with the KeePass Master Password (still sounds wired Wink )
  6. Run "Sync Now" => works
  7. Right click to a connection and log in with an account from KeePass => ASG crashes
I´m not able to use credentials from KeePass with stored Master Password
How did you configure KeePass initially? You need to encrypt by any option but you only write "without master password"?!?

If you didn't specify a MasterPassword and I think you choose "Sync only object names" - point 3 is the first issue - should not ask for a password if no password is set?!? I will check this and use Windows Account for that...

Point 4/5 - you select the foldr where you have configured to sync KeePass - is that right - and there you open properties - but if you don't use a MasterPassword how can you set this now? Or did you set it also in KeePass database before?

6/7 ok - do you have an error message or does it really crash?

Meanwhile I will try to reproduce...
More questions - did you create a credential object that is containing your KeePass MasterPassword? Or do you use an empty credential object - with option "Always prompt for password" for your MasterPassword?
The KeePass DB has a password (of course)

This way I´ve configured the stuff

And yes the KeePass password is an entry in the KP db
Sorry the error message:

In the EventLogs I can find following entry

Quote:Faulting application name: ASGRDElevated.exe, version: 12.0.6504.1, time stamp: 0x5daf8051
Faulting module name: clr.dll, version: 4.8.4018.0, time stamp: 0x5d4a67fe
Exception code: 0xc00000fd
Fault offset: 0x00000000000fac60
Faulting process id: 0x6b74
Faulting application start time: 0x01d593d1f3b23c1f
Faulting application path: C:\Program Files\ASG-Remote Desktop 2019 (X64)\ASGRDElevated.exe
Faulting module path: C:\Windows\Microsoft.NET\Framework64\v4.0.30319\clr.dll
Report Id: 165cafab-5f1e-4d16-8ea2-9a2c0124cf90
Faulting package full name:
Faulting package-relative application ID:
I think I found an issue with "Connect As" and passwords that must be retrieved first from the PW-Manager - we will need some further investigation

But the "KeePass" object can't be an object that is inside the KeePass-database - you need to create a credential object and set there the password (or if not set the program should ask once for the MasterPassword)

I will inform you when we know what is going wrong...
I think I found the issue!

If you do a sync with option "Sync all data" the credentials will be synced to your ASGRD-environment - after that changing the option to "Sync only object names" do not override the information in cred object to retrieve the password directly from KeePass - and it will prompt you to enter the password… we will fix this issue! Only workaround currently is to remove the synced objects and sync again!

And if I choose a cred object that is located in KeePass sync folder for the sync itself - it crashes ASGRD for me too - we will fix this that no one is allowed to choose objects from the sync folder! It can be only done after a first sync but it makes no sense and should not be possible!
Ohh, then it doesn´t sound so wired anymore Wink
But it worked in the past. However, when i create an additional entry and use this one, then everything is working


Users browsing this thread: 1 Guest(s)