Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Server does not support diffie-hellman-group1-sha1 for keyexchange
#1
Beim Verbidungsaufbau mit einem Debian Server bekomme ich von ASG immer die Meldung:
Server does not support diffie-hellman-group1-sha1 for keyexchange

Über Putty direkt funktioniert der Verbindungsaufbau ohne Probleme.

ASG-RemoteDesktop 2020 (13.0.6721.1).
Reply
#2
Hallo Henning,

Wenn über Putty direkt gegangen wird dann ist das ein "normal" installiertes Putty oder das von ASG-RD mitgelieferte ? Wenn dem so ist kann sein dass der bevorzugte Key-Exchange Algorythmus im internen Putty noch umgestellt werden muss, also die Position des diffie-hellman-group1-sha1 for keyexchange nach unten geschoben werden muss, entsprechend dem externen Putty. Bitte mal vergleichen.

Best Grüße,
Michael
-- michael.scholz@asg.com --
Reply
#3
Hallo Michael,

es funktioniert mit beiden, also einmal mit dem normal installierten (Release 0.70) und mit dem in ASG integrierten (Release 0.73).

Getestet habe ich es über "Verbindung Eigenschaften --> SSH --> Sitzung konfigurieren" anschließend geht Putty auf und ich sehe die selben Verbindungen.
Mache ich hier ein Doppelklick auf die gewünschte Sitzung funktioniert die Verbindung, nur innerhalb ASG selber nicht.

Welche Einstellung soll ich konkret vergleichen? Habe auch schon unter Kex die Diffie Hellmann Group nach oben geschieben, aber ohne Erfolg.
Reply
#4
Hallo zurück,

ok danke für die Info ! Ich meinte genau das, schaun welcher key exchange algorythmus ganz oben ist bei den Versionen die standalone funktionieren und dem profil das in ASG-RD verwendet wird. Eigentlich kann es nur an dem Profil liegen - wird das richtige Profil in ASG-RD verwendet ? Denn das einzige was passiert ist das wir Credentials und den Port aus ASG-RD an Putty übergeben, Putty jedoch genauso wie extern funktioniert. Das einzige worauf man achten muss ist dass das richtige Putty Profil genutzt wird.
By the way: wenn der Server meldet das Diffi Hellman Group1 nicht unterstützt wird dann darf dieser Algorythmus nicht oben stehen... bei meinen connections hab ich den ganz unten angeordnet ;-)

Viele Grüße,
Michael
-- michael.scholz@asg.com --
Reply
#5
Also das richtige Profil ist zugewiesen, wenn ich auf Open drücke auch links bin ich direkt in der Sitzung.
Ist es auch möglich eine Fernwartung über TeamViewer oder ähnliches zu machen?

   
(links ASG rechts lokal)
Reply
#6
Hallo Henning,

eigentlich ist direkter Remote Support nicht vorgesehen - über das Forum lässt sich alles in der Regel am besten organisatorisch abhandeln. Jeder nachvollziehbare Schritt hier ist auch ein Benefit für andere Leser der threads. Zurück zum Problem: ganz wichtig ist dass wenn man in der SSH session auf "configure" clickt natürlich erstmal in putty auch nochmal dieselbe session laden muss (load) da sonst andere (default) werte angezeigt werden. Da besteht die Gefahr dass man dann gar nicht die gewollten Sessiondaten anpasst. Putty nimmt ja exakt die Session die in der Registry hinterlegt ist. Ich versuche eventuell mal einen Key Exchange Algorhytmus vorzugeben - kann mir aber nicht vorstellen das es nicht geht.. aber ich melde mich sobald ich es testen konnte.

beste Grüße,
Michael
-- michael.scholz@asg.com --
Reply
#7
Ja ich habe vorher die entsprechende Sitzung auch geladen, sieht hier genau gleich aus.
Habe auch schon die Sitzung aus der Umgebung entfernt und wieder reingeholt - beides ohne Erfolg.

Kann ein SSH Key auch in der Umgebung (in unserem Fall SQL Datenbank) gespeichert werden?
Reply
#8
Hallo Henning,

ja dafür ist der "key-File Administration" Button da : mit "Upload" wird das keyfile in der DB gespeichert und steht dann anderen Installationen zum Download bereit.
:-)
-- michael.scholz@asg.com --
Reply
#9
   
Ich bin nun ein Schritt weitergekommen, nach dem ich eigentlich den Punkt für die Berechtigungen gesucht habe...
Hier habe ich nun mal auf PuTTY umgestellt und schon sieht es auch deutlich besser aus.

Wie Verknüpfe ich den hochgeladenen Schlüssel mit Putty ohne das er es aus meiner lokalen Festplatte laden möchte?
Reply
#10
Hallo Henning,

Ich bin davon ausgegangen dass Putty eingestell ist als default für SSH Verbindungen. Poderosa wird kaum verwendet meines Wissens und hier müssen wir noch entscheiden wie und ob das noch gepflegt werden kann da Putty eigentlich der Standard ist. Bezüglich der Frage: Wir können leider (aktuell) die Keys nicht direkt putty übergeben - die keyfile administration haben wir ja erst eingebaut um überhaupt mal eine Möglichkeit zu schaffen die Keys Netzwerkweit verteilen zu können über die Datenbank. Also aktuell kann man die hochgeladenen bzw. gesyncten keys an jedem Client herunterladen so dass diese dann von Putty auch gefunden werden. Wenn man putty einheitlich konfiguriert hinsichtlich des key Pfades dann ist das schon recht hilfreich und mit einem click gemacht. Weiter reicht die Integration noch nicht...aber wer weiss was die Zukunft bringt ;-)
-- michael.scholz@asg.com --
Reply
#11
Davon bin ich auch ausgegangen, jedoch war dies die Standardeinstellung von ASG - wusste ich auch nicht.

Okay, sprich im Prinzip brauch ich es gar nicht hochladen in die Datenbank sondern kann es auch auf ein Netzlaufwerk legen wo die Kollegen Zugriff haben.
Dann bin ich mal gespannt Wink

Leider funktioniert die Verbindung aus dem ASG noch nicht direkt - nur wenn ich auf konfigurieren geh und dann in dem Putty Fenster die Verbindung starte.
Kann ich irgendwo die Weiterreichung des Benutzernamens deaktivieren - evtl. ist das hier das Problem.
   
Reply
#12
Hallo,

sehr komisch... ich prüfe das nochmal mit der Defaulteinstellung aber meines Wissens nach ist da eher Putty drin...aber wie dem auch sei: wichtig dass es nun past ;-) Bezüglich der weiterreichung der Kennung: das passiert nur wenn für die Connection auch Credentials hinterlegt sind...das sollte der Kennung entsprechen die bei der Putty Session-Definition unter glaub "Data" hinterlegt sind. Credentials in ASG-RD die für die Session hinterlegt sind werden an putty übergeben und überschreiben die putty werte !
-- michael.scholz@asg.com --
Reply
#13
Danke, habe nun einen neuen Account angelegt ohne Kennwort welcher die Vererbte Einstellung überschreibt. Problem ist somit gelöst Smile
Reply




Users browsing this thread: 1 Guest(s)