Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ASG Remote Desktop 2020 x64 Slow start
#1
Hi all, 

Since I have updated to ASG Remote Desktop 2020 x64 (from 2019 version), I have the following problem running on Windows 10 x64: 

Starting ASG Remote Desktop only shows in Tasklist under "Background Jobs". 
This takes a while (30seconds to 60seconds). 
After that it is displayed in apps and shows the login box. 

If you fill in your creadentials and press "Login" the task goes into "Unresponsive" for about 30 seconds. 
After that the normal screen from ASG Remote Desktop appears. 

Anyone have a solution for this?

Thanks, 
   Andreas
Reply
#2
Hi Andreas,
Strange - I can only imagine the udpate check on startup causes a delay - please check that in settings and disable for testing.
Another test would be to run the elevated.exe to see if something changes in behaviour. If you create internal users for login does that also create a unresponsiveness on login ?

best regards,
Michael
best regards,
Michael -- michael.scholz@asg.com --
Reply
#3
Hi @NTTAKR / @Michael

I am also experiencing the same issues with a slow 2 stage response.
1. When opening ASG RDP, it sit's in background processes for about 15-20 seconds, then when the login screen appears, it moves to Apps
2. When in Apps, I now login and it takes a further 20-30 seconds displaying "Not Responding" - eventually logging into the environment.

I have tried both recommendations above but they are not providing any improvement.
In terms of some recent (local) changes.

I have migrated to a New W10 Laptop.
Old Spec - Lenovo P52s, W10 (v.1803) - ASG 2020 Patch 7 was running fast
New Spec - Lenovo P53s, W10 (V.1909) - ASG 2020 Patch 7 running slow.

As a further test - I have just had the old P52s updated to W10 (V.1909).
I'll try testing a clean install of ASG RDP on here and provide the outcome as soon as i have it


Thanks
Barry
Reply
#4
I checked startup using Sysinternals ProcMon, and have found two delays before getting the login prompt:


Code:
9:19:44.3762270 AM ASGRD.exe 1832 CreateFile \\MAC7390-KEN*\MAILSLOT\NET\NETLOGON SUCCESS Desired Access: Generic Write, Read Attributes, Disposition: OpenIf, Options: Synchronous IO Non-Alert, Non-Directory File, Attributes: N, ShareMode: Read, Write, AllocationSize: 0, OpenResult: Superseded
9:19:44.3763481 AM ASGRD.exe 1832 WriteFile \\MAC7390-KEN*\MAILSLOT\NET\NETLOGON BAD NETWORK PATH Offset: 0, Length: 74, Priority: Normal
9:19:48.9265722 AM ASGRD.exe 1832 CloseFile \\MAC7390-KEN*\MAILSLOT\NET\NETLOGON SUCCESS

9:19:48.9313691 AM ASGRD.exe 1832 CreateFile \\MAC7390-KEN*\MAILSLOT\NET\NETLOGON SUCCESS Desired Access: Generic Write, Read Attributes, Disposition: OpenIf, Options: Synchronous IO Non-Alert, Non-Directory File, Attributes: N, ShareMode: Read, Write, AllocationSize: 0, OpenResult: Superseded
9:19:48.9314533 AM ASGRD.exe 1832 WriteFile \\MAC7390-KEN*\MAILSLOT\NET\NETLOGON BAD NETWORK PATH Offset: 0, Length: 74, Priority: Normal
9:19:53.4778800 AM ASGRD.exe 1832 CloseFile \\MAC7390-KEN*\MAILSLOT\NET\NETLOGON SUCCESS

That's a total of about 9 seconds delay (before getting the login prompt) due to timeout for two Mailslot Pings. My laptop is not part of a domain, but my ASG does have domain credentials stored. Could this be this issue?

Ken.
Reply
#5
And then after login there are two further delays caused by Mailslot Pings, again totalling about 9 seconds:


Code:
9:45:20.5332817 AM ASGRD.exe 4596 CreateFile \\MAC7390-KEN*\MAILSLOT\NET\NETLOGON SUCCESS Desired Access: Generic Write, Read Attributes, Disposition: OpenIf, Options: Synchronous IO Non-Alert, Non-Directory File, Attributes: N, ShareMode: Read, Write, AllocationSize: 0, OpenResult: Superseded
9:45:20.5333674 AM ASGRD.exe 4596 WriteFile \\MAC7390-KEN*\MAILSLOT\NET\NETLOGON BAD NETWORK PATH Offset: 0, Length: 74, Priority: Normal
9:45:25.0657242 AM ASGRD.exe 4596 CloseFile \\MAC7390-KEN*\MAILSLOT\NET\NETLOGON SUCCESS

9:45:25.0837128 AM ASGRD.exe 4596 CreateFile \\MAC7390-KEN*\MAILSLOT\NET\NETLOGON SUCCESS Desired Access: Generic Write, Read Attributes, Disposition: OpenIf, Options: Synchronous IO Non-Alert, Non-Directory File, Attributes: N, ShareMode: Read, Write, AllocationSize: 0, OpenResult: Superseded
9:45:25.0838948 AM ASGRD.exe 4596 WriteFile \\MAC7390-KEN*\MAILSLOT\NET\NETLOGON BAD NETWORK PATH Offset: 0, Length: 74, Priority: Normal
9:45:29.6287759 AM ASGRD.exe 4596 CloseFile \\MAC7390-KEN*\MAILSLOT\NET\NETLOGON SUCCESS

So, while I'm not experiencing the 30+ seconds delay reported above, 9 seconds both sides of the login prompt is still significant!

Edit: Okay, I forgot I had VPN connected when I ran the above tests. With VPN disconnected, there are still 2 delays, each side of login, but each delay is now 2.25 seconds instead of 4.5 seconds, so a total of 4.5 seconds each side of login. This post here may be relevant: https://social.technet.microsoft.com/For...inserverDS

Ken.
Reply
#6
As per the above link I posted, I disabled NetBIOS over TCP/IP for my laptop's network and VPN interfaces (IPv4 properties), and now startup of ASG RD both sides of the login prompt is instant.

Ken.
Reply
#7
I have the same problem.

From launch to login box is fast about 2-3s

But after login it takes about 60-120 seconds and "not responding" message appears.
loading data 5-15sec
clear up logs 20-40
time after "clear up logs" "not responding" 30-50

Version 13.0.6888.1
dataoptimizer run today no change.
Reply
#8
(18-05-2021, 02:42 AM)kw_broadens Wrote: As per the above link I posted, I disabled NetBIOS over TCP/IP for my laptop's network and VPN interfaces (IPv4 properties), and now startup of ASG RD both sides of the login prompt is instant.

Ken.

Thanks Ken,

I did the same (just disabled NetBios) in Windows 11 Pro and it solved the problem for me too. Was taking 20-30s to load, now takes approx 1s.

Not sure what adverse effects I might see from disabling NetBios, but probably none.

Simon.
Reply
#9
An update. My ASG start up time recently became long again. I realised this happened after I installed VMware Player, which created two network adapters. It is necessary to disable NetBIOS over TCP/IP on *every* active network adapter, including VMWare adapters!

Ken.
Reply
#10
Thanks - could be really helpful for other customers :-)
Regards/Gruss
Oliver
Reply




Users browsing this thread: 2 Guest(s)