Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ASG 2020 not using the local keyboard layout via RDP/SSH
#1
Hi all,
we have ASG 2020 Version 13.0.6768.1 running in our company. By default, we use the german ISO Keyboard layout, with my exception perferring the US ANSI. Now I have the issue, that in every ASG connection, regardless of SSH or RDP im forced to the ISO-DE layout. Is there any way in the ASG client to use my local keyboard layout that is selected within Windows? 

In the company I worked before we used mRemoteNG and Devolutions Remote Desktop, using my ANSI layout was no problem there so that would be great with ASG too.
Reply
#2
We will check that...
Regards/Gruss
Oliver
Reply
#3
Perhaps the solution is a simple reg key - found this article

https://blog.rdparena.com/2014/09/changi...ge-in.html

But didn't test it myself...
Regards/Gruss
Oliver
Reply
#4
Unfortunately I just get a 404 on that Link
Reply
#5
https://blog.rdparena.com/2014/09/changi...ge-in.html
Regards/Gruss
Oliver
Reply
#6
(18-02-2022, 01:26 PM)DevOma Wrote: https://blog.rdparena.com/2014/09/changi...ge-in.html

I did try the setting, didnt work for me. And tbh that would be kind of a bad solution for me, cant set a registry key at like 200 or more servers...

I had a look at what I was using in my old company, the setting "Options > Local Resources > Keyboard to set 'Apply windows key combinations' to 'On the local computer' did exactly the right thing and I had my ANSI Layout while being connected to a machine with ISO and without having to change anything. Is that possible in ASG too?
Reply
#7
Will check that again...
Regards/Gruss
Oliver
Reply
#8
Hi, any news?
Reply
#9
No sorry, still pending...
Regards/Gruss
Oliver
Reply
#10
Did you try the same with mstsc.exe? Is the same issue or not? Because I searched again for a solution but always the solutions are that you need to configure it on the remote machines by a RegKey
Regards/Gruss
Oliver
Reply
#11
With the setting set in the msc.exe it works also there flawless.

[Image: asg2020notusingtheloce3kis.png]

We just did the same change in ASG for one connection testwise, actually that did the change. Just a sign out on the connection had to be made. I also didnt notice any issues in the SSH connections anymore, even if ASG gets started with DEU-DE in Windows and later changed to DEU-INTL. First time I tested that, I never got the correct keystrokes in SSH sessions. No Idea what did the change, but now it seems to work as it should.
Reply
#12
Great - thanks for your feedback!
Regards/Gruss
Oliver
Reply




Users browsing this thread: 2 Guest(s)