Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Environment Connect button Greyed out Under Citrix
We are testing 2015 under Citrix. Already using 2012 under the same environment. After creating a new 2015 Db. Then we created the DB environment locally and did the upgrade inside. Upon trying to connect under a citrix launch, the environment manager comes up but the "Connect" button is greyed out.
Here's the 2012 cmd line parameters
"C:\Program Files (x86)\ASG-Remote Desktop 2012\ASGRD72.exe" /passthrough:true /noenv /instance:vRDDb2012
Here's the 2015 cmd line parameters
"C:\Program Files (x86)\ASG-Remote Desktop 2015\ASGRD.exe" /loginintegrated:true /loginsubmit /noenv /instance:ASGRD2015 - But this just exits so used without the loginsubmit
"C:\Program Files (x86)\ASG-Remote Desktop 2015\ASGRD.exe" /loginintegrated:true /noenv /instance:ASGRD2015 which gives us the screen shot attatched.
I think it might be a permissions thing?

Further to this, I then created another enviroment in the Env Manager screen, I can connect to this in that session. But then launching a new ASGRD session gives the greyed out connect button again for both environments

Using Patch-1 version v8.0.4721.0

Attached Files Thumbnail(s)
Anybody else come across this under Citrix. We have 300 citrix users who I can't upgrade to 2015 untill this is fixed. Works fine under 2012.
If I connect to the servers desktop and run the same command line from cmd prompt, ASG starts as expected. So it's something different in the way 2015 works under Citrix XenApp compared with 2012...
Do you use Patch1? The /loginsubmit command line parameter didn't work in first RTM - with Patch1 it should work
Yes using Patch 1 ver v8.0.4721.0.
We also use the /instance:xxxx cmd line but this doesn't connect to the env, only brings up the manager
If I use /loginsubmit nothoing happens.
If I don't use it then the env manager comes up and selecting an env the connect button is greyed out. ie can't connect to env.
Can you give me your complete command line that you are using? We a lot of possible combinations for Patch1 and everything worked fine...
Begining of the thread has the cmd line string..

Further: I tried running the cmd line directly from a Citrix Desktop session, and it connected successsfully. With both
"C:\Program Files (x86)\ASG-Remote Desktop 2015\ASGRD.exe" /instance:ASGRD2015 /noenv /passthrough:true /loginsubmit
"C:\Program Files (x86)\ASG-Remote Desktop 2015\ASGRD.exe" /instance:ASGRD2015 /noenv /loginintergrated:true

If either is run as a Citrix Published app, the Connect button is greyed out. As in the attatched image.
Ok, please try it without /noenv and try to login manually - does that work? Seems to be a problem with login and you don't get a message in silent login mode
Ok, I removed the /noenv which does allow the connect button now.
But we want to hide the Environment so need to fix this.

Also, even tho we have specified /instance:ASGRD2015 it doesn't auto connect to the env, just brings up the Env manager.
Could you please check your environments.xml file - perhaps there is a whitespace in the name- for databases it should be under "ProgramData\ASG RemoteDesktop\8.0" - I will check it later if it should preselect the environment - but perhaps the name of the env is not identical and that's why the login don't work
No whitespace in name. hERE'S THE XML...

<ArrayOfEnvironmentData xmlns:xsi="" xmlns:xsd="">
<ConnectionString>Data Source=[I HAVE HIDDEN THIS];Initial Catalog=ASGRD2015;Integrated Security=True</ConnectionString>
I tried again - and I got an error message if I use "/pasthrough:true" - I will check (and fix) that... Your second command line does not include "/loginsubmit" - did you add this in your tests? On my testing machines it always logs me on if I set /loginsubmit

Try the following command line

"C:\Program Files (x86)\ASG-Remote Desktop 2015\ASGRD.exe" /instance:ASGRD2015 /noenv /loginintegrated:true /loginsubmit

And now as I copied your cmd line I see there is a syntax error :-) Look at "loginintegrated" - there was an "r" to much in it (/logininte"r"grated) :-) Hope now it will work for you too!
If I use "C:\Program Files (x86)\ASG-Remote Desktop 2015\ASGRD.exe" /instance:ASGRD2015 /noenv /loginintegrated:true /loginsubmit in a Command Prompt on the citrix desktop it launches as expect. But I have to actually be in a Desktop session.
The following are in in the settings of the command line of the published application.
If I use the same line as a published app then the published app fails to launch.
So I removed the /loginsubmit and used "C:\Program Files (x86)\ASG-Remote Desktop 2015\ASGRD.exe" /instance:ASGRD2015 /noenv /loginintegrated:true then the env manager is displayed but connect button is greyed out.
SO I removed the /noenv and used "C:\Program Files (x86)\ASG-Remote Desktop 2015\ASGRD.exe" /instance:ASGRD2015 /loginintegrated:true then env manager comes up and I can select the env and use the connect button.
So not sure what is going on. My orginal line with the "r" was untill I looked at the help and saw how you spelled integrated on the cmd line.
Why is the env not being auto selected in the citrix published app?
Hm, this issue is getting strange :-)

So let me share my thoughts with you - the ussage of /noenv makes only sense if the login is also in command line because the user isn't allowed to connect to any environment- so everything ok in this case

One difference between the start of the command in Desktop mode to Citrix mode could be the working dir - is it set correctly in the Citrix App? And the permissions could be different?

Once more - if I specify the command line without /loginsubmit I get the login dialog and not the Environment Wizard!?! Is there a difference between Citrix and Desktop mode? Do you have any application ebent log entries if the login do not pass?
We use the /noenv as their are multiple database environments that have to run from specific servrvers and /noenv means the user once connected, can't go in and change their environment from the asg gui.
Desktop mode is just the Citrix Server Desktop as a published app. In essence a terminal servers session to the server providing the full desktop
App mode is the Published App where you specify the command line parameters to launch the app. This is in a Terminal Server session. SImilar to a Terminal Server session where you specify the app to run on login.
I can confirm the settings are the same as for the ASG 2012 vrsion that works fine.
I will give this issue to the QA team - they can reproduce it on a Citrix farm - but it will take some days (because of holiday season)
Thanks for that. We're on holiday from 23rd to 14th Jan, so all good..
I haven't deployed 2015 for the users as yet, the're still using 2012. So doesn't affect production.
Hope you have a happy christmas etc..
Sorry fo the delay - but we had to fix and test some other issues before - but now we tested as Published App - used a lot of possible command line parameters and everything worked well - it must be something else
--Working Now--
I can happily say that after installing Patch4, the app launches via citrix published app and connects to the db instance and logs in ok now.
Our cmd line is
"C:\Program Files (x86)\ASG-Remote Desktop 2015\ASGRD.exe" /noenv /loginsubmit /instance:ASGRD2015 /loginintegrated:true
Great work..


Users browsing this thread: 1 Guest(s)